Gnu GRUB version 0.97 (639K lower / 1039040K upper memory)

COMO RESOLVER PELA BIOSConfigurar SATA (1)

Recentement, ao instalar mais um servidor(zito), optei pela última versão do CentOS, a 6.4. A instalação decorreu sem novidades, o volume RAID-1 por hardware foi devidamente reconhecido e depressa chegou a altura de reiniciar o pc para terminar a instalação. E aqui é que a burra torceu a porca. Ou é ao contrário? Não, é a burra torceu o rabo. Tosco.

Ligo o botão e nada. Isso mesmo, nada. Um ecrã preto com estas lindas palavras (a quantidade máxima de memória reportada varia com a quantidade de memória instalada):

Gnu GRUB verion 0.97 (639K lower / 1039040K upper memory)

[Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ]

O que foi,  no mínimo, estranho. A instalação correu perfeitamente, sem qualquer indício de erros ou incompatibilidades. Confirmei, manualmente, a instalação do bootloader em “/sda”. Placa-principal comum, processador Intel P4 (775) e memórias de qualidade. Até aqui tudo bastante normal e compatível. O computador é que, em virtude dos seus nove anos, levantou algumas dúvidas. Mas limpo, testado e com uma fonte de alimentação e cooler novos não havia razões para desconfiar mais da máquina.

E MAIS UMA VEZ O GOOGLE

Não tinha a resposta que eu queria. Aquela que iria permitir-me, preguiçosamente e num passe de mágica, pôr a coisa a bombar em 3 segundos. Sem gastar mais brain-power. O Google tinha, de facto, muitas respostas espalhadas por outros tantos fóruns. Mas todas baseadas no pressuposto que o Grub estava avariado. Ora eu tinha acabado de descarregar a “iso” e verificado o checksum. Ná, para mim a questão era outra. E aquela referência aos limites de memória, aqui, porquê? O processo de boot tem a ver com BIOS, disco rígido, bootloader e sistema operativo. Parecia que o disco não estava onde o  Grub esperava. Seria?

ALTURA DE VER AS CONFIGURAÇÕES

Da BIOS e ver o modo como os discos rígidos estavam configurados. Sabia que não era AHCI, pois queria ter suporte para discos IDE e configurei a BIOS nesse sentido. Experimentando com um dos outros modos permitidos, e testando o resultado, depressa o pc encontrou tudo o que queria, onde queria. E arrancou o CentOS 6.4, feliz da vida. Portanto, se se depararem com este problema dêm, primeiro, um olhito nas configurações da BIOS. Ficam as imagens.

Configurar SATA (2)

Configurar SATA (3)

Configurar SATA (4)

Até sempre;

SonhosDigitais
Anúncios